MSA-21-0011: JQuery versions below 3.5.0 contain some potential vulnerabilities (upstream)

by Michael Hawkins.  

The JQuery version used by Moodle required upgrading to 3.5.1 to patch some published potential vulnerabilities.


Severity/Risk:Minor
Versions affected:3.10 to 3.10.1, 3.9 to 3.9.4, 3.8 to 3.8.7, 3.5 to 3.5.16 and earlier unsupported versions
Versions fixed:3.10.2, 3.9.5, 3.8.8 and 3.5.17
Reported by:Mike Henry
CVE identifiers:CVE-2020-11022 and CVE-2020-11023
Changes (master):http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-69680
Tracker issue:MDL-69680 JQuery versions below 3.5.0 contains some potential vulnerabilities

Read more https://moodle.org/mod/forum/discuss.php?d=419655&parent=1691274